Profitability Features

CloudLinux OS Shared/ CloudLinux OS Shared Pro Features

Stability features

Security features

profitability features

Performance features

The PHP Selector allows end-users to select the specific version of PHP they need. It allows ultimate flexibility by offering all popular versions of PHP, with more than 120 PHP extensions to choose from.

Each of your customers is different, and each has different needs. With PHP being the dominant language on the internet, we package multiple versions of PHP and let the customer select which version they want to run. Customers can select between PHP 4.4, 5.1, 5.2, 5.3, 5.4, 5.5, 5.6, and 7.0, 7.1 and 7.2. They can also select from more than 120 different PHP extensions.

Quite often, a customer needs one extension while another customer needs a different extension. Without CloudLinux OS Shared, the way to handle this is to move the customer to VPS, which is often costly and might encourage your customer to move to a different hosting provider. No more. CloudLinux provides a large number of extensions and gives control to the end-user. Only users who need it will use the PHP selector. Everyone else will use the default PHP version that you have installed on your server. Customers can switch to a different version of PHP at any time.

The Ruby Selector allows end-users to select the specific version of Ruby they need.

Each of your customers is different, and each has different needs. The Ruby Selector allows end-users to choose the Ruby version for applications and install additional modules (gems) to the application environment. Ruby Selector uses mod_passenger for optimum performance.

Without CloudLinux OS Shared, the way to handle a customer needing a different version of Ruby is to move the customer to VPS, which is often costly and might encourage your customer to move to a different hosting provider. No more. CloudLinux OS Shared gives control to the end-user. Only those users who need it will use Ruby Selector.

The Ruby Selector is available for CloudLinux 6 or later and requires LVE Manager 0.9-1 or later. However, as an administrator, you can choose to simply hide the Ruby Selector option and it will not appear in the user interface.

The Python Selector allows end-users to select the specific version of Python they need.

Each of your customers is different, and each has different needs. The Python Selector allows end-users to choose the Python version as an application and install additional modules. Python Selector uses mod_passenger to get the best performance from Python applications.

Supported Alt-Python versions include:

alt-python27 2.7.9, supported by CloudLinux 5-7
alt-python33 3.3.2, supported by CloudLinux 6-7
alt-python34 3.4.1, supported by CloudLinux 6-7
alt-python35 3.5.4, supported by CloudLinux 6-7

The Python Selector requires LVE Manager 0.9-1 or later. However, as an administrator, you can choose to simply hide the Python Selector option and it will not appear in the user interface.

Without CloudLinux OS Shared, the way to handle a customer needing a different version of Python is to move the customer to VPS, which is often costly and might encourage your customer to move to a different hosting provider. No more. CloudLinux OS Shared gives control to the end-user. Only those users who need it will use Python Selector.

Test the unlimited license for free now. No credit card required. We value your privacy.

I’d like to receive information about CloudLinux.

 



 
By clicking Start Trial Now button, you agree with our Privacy Policy .

Supports PHP versions 4.4, 5.1-5.6, and 7.0-7.2

Supports 120 PHP extensions

CloudLinux OS Shared includes a large number of extensions and gives control to the end-user. As part of the CageFS tool, each customer can select their PHP version. CloudLinux makes sure that PHP is updated fast, making sites more secure and customers happier.

Learn more about PHP Selector from documentation

Supports Ruby versions 1.8, 1.9, 2.0, and 2.1

Allows users to install additional modules to application environments

Learn more about Ruby Selector from documentation

Supports Python versions 2.7, 3.3, 3.4, and 3.5

Allows users to install additional modules to application environments

Learn more about Python Selector from documentation

Install on

SERVER WITHOUT CONTROL PANEL